怎样保护越狱的 iPhone 免受泰卢固语“文本炸弹”错误的影响

在过去的几天里,由于操作系统无法以泰卢固语(一种印度语言)呈现特定字符,泰卢固语字符错误导致 iOS 应用程序(如消息)在 iPhone 或 iPad 上崩溃。 Apple 通过发布 iOS 11.2.6 软件更新解决了这个问题。 然而,越狱者只能使用旧版本的 iOS。 在这里,我们将向您展示怎样保护运行旧固件的越狱 iPhone 或 iPad 免受泰卢固语“文本炸弹”错误的影响。

如果您有越狱的 iPhone/iPad 或遵循coolstar 的建议避免升级到 iOS 11.2.5 或更高版本,那么您就无法自由安装带有泰卢固语字符错误修复程序的最新版本的 iOS。

越狱社区的好处是,开发人员已经发布了一个名为 NotTodaySatan 的越狱调整,以增加对越狱设备的保护,防止泰卢固语字符错误。 安装后,该调整将保护您的 Springboard 和应用程序免于崩溃。

这个调整的作用是用占位符文本替换泰卢固语字符。 如果您有越狱的设备,我们建议您安装调整以防止可能导致您恢复设备而导致越狱失败的崩溃。

如果您可以对越狱设备稍加修改,Reddit 用户还提供了一种替代方法来解决该问题:

首先,打开一些具有 root 访问权限的文件管理器(如 Filza 或 iFile)
转到/系统/库/字体/核心/
搜索 KohinoorTelugu.ttc
重命名其后缀(或删除)
重新启动,你就完成了
现在字符应该出现矩形或问号。 你完成了!

由于 Apple 已经修复了 iOS 11.2.6 中的泰卢固语错误,因此任何运行 iOS 11.2.6 的 iPhone 或 iPad 都不容易出现此类“文本炸弹”错误。

如果您有越狱设备并且上述解决方案可以避免泰卢固语字符错误,请在下面的评测部分告诉我们。

相关阅读:

Posted in: AppleTags: , ,