Jake James通过64位iOS 10支持更新了Sock Port和Sock Port 2漏洞

越狱者最近甚至没有眨眼就没有关于漏洞利用或越狱工具更新的消息,而且似乎没有迹象表明这种情况很快就会放缓。

虽然大部分新闻都涉及通过更新和更有效的利用来增加对较新固件版本的支持,但黑客和无根JB 3.0开发人员Jake James今天早晨发布Sock Port和Sock的更新版本时有些动摇。端口2 tfp0漏洞利用对运行iOS 10.0-10.3.3的64位设备的支持:

Jake James通过64位iOS 10支持更新了Sock Port和Sock Port 2漏洞 1

从我们的收集来看,这些漏洞利用功能不适用于iPhone 5和更早版本的32位设备,但这仍然是个好消息,因为它向可能希望进行新越狱的iOS 10用户扩展了橄榄枝。 Luca Todesco的Yalu工具。

值得注意的是,从未开发的领先开发商Pwn20wnd在James开始取笑后不久就表达了对该漏洞的兴趣。 尽管这不是一个承诺,但它表明unc0ver有一天可能会获得iOS 10支持,并将其转变为比现在更通用的越狱工具:

Jake James通过64位iOS 10支持更新了Sock Port和Sock Port 2漏洞 2

詹姆斯有 在GitHub上发布了他的更新漏洞 带有完整的书面PDF 在这里可用。 以下是发行说明:

适用于所有设备的iOS 10.0-12.2 tfp0(理论上)。

一些信息:

  • 使用Ned Williamson的套接字错误
  • 使用Ian Beer,machswap,SockPuppet的一些东西
  • 其余代码均根据GPL进行了许可,除非明确授予了分发封闭源代码的权限(unc0ver团队,pwn20wnd和sbingner拥有此权限)

写上去: https://raw.githubusercontent.com/jakeajames/sock_port/master/sock_port.pdf

感谢Pwn20wnd和GeoSn0w及用户帮助在多个设备(和Corellium)上进行测试。

您是否希望unc0ver通过James的新Sock Port漏洞获得iOS 10支持,还是只希望越狱以后的固件版本? 在下面的评测部分让我们知道。