怎样在 Linux 中安装和使用 Yarn 包管理器

在本教程中,我们将讨论什么是 ,怎样在Linux中安装Yarn包管理器,最后我们来看看Yarn的基本用法。

内容

  1. 纱线介绍
  2. 在 Linux 中安装 Yarn 包管理器
    1. 将 Yarn 1.x 升级到 Yarn 2
  3. 纱线入门
    1. 1. 显示帮助部分
    2. 2. 开始一个新项目
    3. 3.安装依赖
    4. 4.安装包
    5. 5.升级包
    6. 6. 显示包裹信息
    7. 7.执行shell命令
    8. 8. 显示安装包的原因
    9. 9. 显示工作区
    10. 10.显示当前配置设置
    11. 11.查看插件
    12. 12. 下载插件
    13. 13.删除插件
    14. 14. 删除包
    15. 15. 移除缓存

纱线介绍

纱线,代表 一种另一个 电阻资源 Navigator 是一个现代包管理器,用于在 Linux、macOS 和 Windows 操作系统中安装和管理 JavaScript 程序。

Yarn 是一个快速、安全和可靠的包管理器。 纱线完全兼容 npm registry 并且可以一起工作 npm 包管理器。

它同时执行所有操作以最大化资源利用率并缓存每个下载的包。 因此,无需一遍又一遍地下载相同的软件包。 Yarn 在设计上也是安全的,因为它在安装前使用校验和来确保每个包的完整性。

默认情况下,Yarn 支持 节点. 您还可以使用插件将支持扩展到其他编程语言。 尽管 Yarn 命令的用法与 Npm 类似,但它还有一些额外的命令。 例如,它有 "yarn why" 命令,它告诉您为什么安装某个软件包。

纱线最初是由 Facebook 使用 npm 解决和修复性能和安全问题。 现在 Yarn 是一个独立的开源项目 Facebook 也没有任何其他公司。

在 Linux 中安装 Yarn 包管理器

Yarn 在我的许多 Linux 发行版的默认存储库中可用。 但是,官方推荐的安装 Yarn 的方式是使用 净功率,Nodejs 包管理器。

默认情况下,Npm 将随 Nodejs 安装一起安装。 对于 Linux 上的 Nodejs,请参考以下指南:

  • 怎样在 Linux 上安装 NodeJS

安装Nodejs后,使用 高于海平面 在你的 Linux 机器上安装 Yarn:

$ npm install -g yarn

检查安装的 Yarn 版本:

$ yarn --version
1.22.10

正如你在上面的输出中看到的,安装的 Yarn 版本是 1.22.10.

将 Yarn 1.x 升级到 Yarn 2

Yarn 的开发者建议从 Yarn 1.x 版本迁移到 2.x 版本以获得快速稳定的 Yarn 体验。

要将 Yarn 1.x 迁移到 Yarn 2,请转到您的项目文件夹并运行以下命令以升级到 Yarn 2 版本:

$ yarn set version berry

这里, berry 是 Yarn 2 发布版本的代号。 您可以使用以下命令检查版本:

$ yarn --version
 2.4.1

您也可以使用以下命令将 Yarn 1.x 版本永久升级到 Yarn 2.x 版本:

$ yarn set version latest

使用命令检查 Yarn 是否成功升级:

$ yarn --version
2.4.1

伟大的! Yarn 已迁移到 2.x 版本。 在撰写本指南时,最新的 Yarn 版本是 2.4.1.

纱线入门

我们已经安装了 Yarn 并将其升级到最新版本。 现在,让我们学习一些基本的 Yarn 命令。

1. 显示帮助部分

要查看可用 Yarn 命令的列表,请通过运行以下命令参考 Yarn 帮助部分:

$ yarn help

该命令将列出所有 Yarn 命令,包括它们的选项/标志以及每个命令的简短描述。 您还可以显示任何子命令的帮助部分,如下所示:

$ yarn add -h

或者,

$ yarn add --help

Yarn 帮助部分给我留下了深刻的印象。 每个 Yarn 子命令的帮助部分都整齐地写着 example 命令。 所有命令的帮助部分都非常详细,所有选项都进行了彻底的解释。 我想您不需要任何在线文档。 一切都可以从离线获取。

2. 开始一个新项目

运行以下命令启动一个新项目:

$ yarn init

此命令将使用当前用户的名称创建一个新项目。

示例输出:

{
   name: 'ostechnix'
 }

3.安装依赖

要为我们的新项目安装所有必需的依赖项,请运行:

$ yarn

或者,

$ yarn install

4.安装包

我们可以使用安装额外的包或依赖项 yarn add 命令。 有几种方法可以使用 yarn 命令添加新包。

要添加常规包,对于 example lodash, 到当前工作区,运行:

$ yarn add lodash

您可以使用以下命令将特定版本的包添加到当前工作区:

$ yarn add [email protected]

您还可以从 主分支 使用 URL 将 GitHub 存储库转移到当前工作区:

$ yarn add [email protected]://github.com/lodash/lodash

或者使用如下的 GitHub 协议:

$ yarn add [email protected]/lodash

如果要添加不同类别的依赖项,请使用 --dev 添加开发依赖项的标志和 --peer 添加对等依赖项。

$ yarn add lodash --dev
$ yarn add lodash --peer

就像我已经说过的,我们可以使用显示 Yarn 子命令的帮助部分 -h/--help 旗帜:

$ yarn add -h

5.升级包

要使用 Yarn 升级包,请运行:

$ yarn up lodash

6. 显示包裹信息

要显示与包相关的信息,请运行:

$ yarn info lodash
└─ [email protected]:4.17.21
└─ Version: 4.17.21

如果要使用 yarn 显示有关包的所有可用信息,则命令为:

$ yarn npm info lodash

7.执行shell命令

我们可以执行一个shell命令 yarn exec 命令。

为了 example,让我们用 Yarn 显示一个 Hello World 文本,如下所示:

$ yarn exec echo Hello World
Hello World

使用 Yarn 命令显示 Linux 内核版本:

$ yarn exec uname -mrs
Linux 5.4.0-72-generic x86_64

8. 显示安装包的原因

这是 Yarn 的独特之处之一。 Yarn 可以显示安装包的原因。

$ yarn why lodash

9. 显示工作区

Yarn 的另一个显着特性是工作区。 Workspace 允许用户从多个安装依赖项 package.json 单个根目录下的子文件夹中的文件 package.json 文件,一气呵成。

要打印所有可用的工作区,请运行:

$ yarn workspaces list

10.显示当前配置设置

要打印当前的活动配置设置,请运行:

$ yarn config

11.查看插件

要直接从 Yarn 存储库打印可用的插件,请运行:

$ yarn plugin list

上面的命令显示所有可用的官方插件。 如果只想显示当前活动的插件,请运行:

$ yarn plugin runtime

12. 下载插件

我们可以从官方 Yarn 存储库或本地或第三方存储库下载和激活插件。 如果您从第三方存储库添加插件,请输入插件的 URL。 如果您从本地系统添加插件,只需输入其路径。

下载并激活插件,对于 example plugin-version,从 Yarn 存储库,运行:

$ yarn plugin import @yarnpkg/plugin-version

13.删除插件

要删除从 Yarn 存储库导入的插件,请运行:

$ yarn plugin remove @yarnpkg/plugin-stage

如果您已从本地系统导入它,只需提及其名称即可。

14. 删除包

要使用 Yarn 卸载软件包,请运行:

$ yarn remove lodash

15. 移除缓存

要删除所有本地存档,请运行:

$ yarn cache clean

您还可以删除存储在 ~/.yarn 目录使用命令:

$ yarn cache clean --mirror

这些足以开始使用 Yarn 包管理器。 但是,有许多命令可用。 我会把它们留给你去学习和实验。 您可以使用以下命令查看 Yarn 命令的完整列表 yarn --help 命令。 如果您不知道特定子命令的用法,请运行 "yarn sub-command -h" 调出该特定命令的帮助部分。

资源:

相关阅读:

Posted in: LinuxTags: ,