怎样在 Ubuntu Linux 上安装 Zlib

兹利卜 是一个用于数据压缩的开源库。

作为最终用户,您可能会遇到需要将 Zlib(或 zlib devel 包)安装为另一个应用程序的依赖项。

但问题来了。 如果你尝试在 Ubuntu 上安装 Zlib,它会抛出“无法定位包 zlib”错误。

sudo apt install zlib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package zlib

为什么你看到这个无法定位包错误? 因为没有名为 zlib 的包。

如果你使用 apt search 命令,你会发现有几个包可以让你安装 zlib: zlib1g 和 zlib1g-dev. 获得这些信息后,只需一个 apt 命令即可安装它们。

在基于 Ubuntu 的 Linux 发行版上安装 Zlib

打开终端并使用以下命令:

sudo apt install zlib1g

请记住,g 之前的字母是 1(一),而不是小写的 L。很多人在键入命令时都会犯这个错误。

另一个包 zlib1g-dev 是开发包。 仅在需要时才安装它,否则您应该使用主运行时 zlib1g 包。

sudo apt install zlib1g-dev

您也可以下载Zlib的源代码 从它的网站 并安装它。 但是,除非您有充分的理由,否则我不建议仅使用源代码方式来安装 zlib。 为了 example,如果您需要最新或特定版本的 zlib,而该版本在发行版的存储库中不可用。

有趣的是,像安装 zlib 这样看似很小的东西可能会因为两个原因而变得痛苦:不同的包名和包含“隐藏”数字一 (1) 的包名,该数字与小写 L 混淆。

我希望这个快速提示可以帮助你。 随意在评测部分留下您的问题、建议或简单的“谢谢”。



相关阅读:

Posted in: LinuxTags: