您现在可以安装旧版 Raspberry Pi OS

基于 Debian 11 ‘Bullseye’ 的官方 Raspberry Pi OS 的最新版本增加了许多新功能和改进。 但是,一些 Raspberry Pi 用户要求回滚操作系统的某些部分以恢复某些项目所需的某些功能。

因此,Raspberry Pi 基金会提供了一个“传统”版本的操作系统。 让我们来看看它以及您可能需要它的原因。

Bullseye有什么变化?

作为一项重大更新, Bullseye 版本的 Raspberry Pi OS 具有相当多的变化。 最值得注意的是,所有桌面组件和应用程序现在都使用 GTK+ 用户界面工具包的第 3 版,而不是第 2 版。

在具有 2GB 或更多 RAM 的 Raspberry Pi 型号上,使用了新的 Mutter 窗口管理器而不是以前的 Openbox,从而产生了更加现代和吸引人的桌面用户界面。 还有一个切换到 KMS 视频驱动程序的开关,用于控制与显示器的连接。

对于 Raspberry Pi 相机模块的用户,Bullseye 已放弃对用于拍摄静止图像和视频的旧 raspistill 和 raspivid 工具的支持,转而支持 libcamera。

Bullseye 的好处是它甚至可以让您的 Raspberry Pi 4 运行得更快。

有什么问题?

正如 Raspberry Pi 首席产品官 Gordon Hollingworth 在 官方博文,迁移到操作系统的新上游分支可能会给某些用户带来严重问题。

“随着新分支的出现,新版本的库和新界面也随之而来。 旧的软件和界面变得不受支持,做特定事情的方式发生了变化,”Hollingworth 说。

这可能会给一些用户带来问题,包括教育用户和使用 Raspberry Pi 运行工业应用程序的用户,他们重视不变的操作系统或开发了使用特定库版本的软件。

什么是 Raspberry Pi OS(旧版)?

Raspberry Pi OS 的替代旧版版本回滚某些更改以恢复某些用户一直依赖的功能。

Legacy 在之前的版本 Raspberry Pi OS Buster 的基础上,将 Bullseye 的 Chromium 硬件加速版本替换为上游软件浏览器。

Linux 内核在 5.10.y 分支,仅从 Linux 内核获取安全补丁。 Raspberry Pi 固件是分支的,只需要现有产品的安全和硬件支持补丁。

相机控制

Raspberry Pi OS Bullseye 中用于相机模块的新 libcamera 驱动程序不再适用于 Picamera Python 绑定。 虽然后者的新版本 Picamera2 正在开发中,但目前无法通过 Python 程序轻松操作相机。

Raspberry Pi OS (Legacy) 具有用于拍摄静止图像和视频的早期 raspistill 和 raspivid 命令,它们将与 Python 中的 Picamera 库一起使用。

Bullseye 用户仍然可以恢复对 raspistill 和 raspivid 的访问。 首先,确保操作系统是最新的,然后打开终端窗口并输入 sudo raspi 配置. 去 接口选项, 然后选择 旧相机 并重新启动。

我怎样获得遗产?

Raspberry Pi OS (Legacy) 可从官方下载 树莓派软件页面, 在桌面版和精简版中。 它也可以在 树莓派操作系统(其他) 的菜单 Raspberry Pi Imager 工具 用于刷入 microSD 卡。 Legacy 可以在任何 Raspberry Pi 型号上运行,包括新的 Zero 2 W。

对于 Debian Buster,支持将持续到 2024 年 6 月。对于 Linux 5.10 内核,支持将持续到 2026 年 12 月。请注意,如果 Debian Bookworm 在此期间稳定,Raspberry Pi OS (Legacy) 将切换到 Bullseye。

回滚到旧版

虽然最新的 Bullseye 版本的 Raspberry Pi OS 提供了许多新特性、额外功能、更大的开源和 Linux 标准化以及改进的用户友好性,但它可能并不适合所有用户。

因此,“新”旧版启用提供了一种方法来坚持使用基于 Buster 的替代 Raspberry Pi OS 分支,并且根据 Raspberry Pi 博客文章,它将“在各种组件继续接收更新的同时保持支持。”